Strommessung am LP erfolgreich

    • Strommessung am LP erfolgreich

      Hallo Zusammen,

      morgen in der Firma will ich meinen LP inkl. Touch-LCD in Betrieb nehmen. Dabei wollte ich direkt Fotos vom Stromverbrauch machen.

      1. Habt ihr vielleicht Links zu einfachen Lasttest-Software mit der ich den LP "etwas" ins schwitzen bringen kann ?
      2. Mit welcher Software messt ihr die Kerntemperaturen ?


      Schönen Restsonntag noch,
      Lodin
    • So, die ersten Versuche sind gelaufen. 8o



      Ein LP 4GB/64GB mit W10, USB-Maus und -Tastatur, 7''-LCD
      Ansteuerung per Teamviewer (für die LCD sind meine Augen zu alt...)

      Maximale gesehene Stromaufnahme 1.7A an 5.00V.
      Stromaufnahme stark schwankend zwischen 0.7 und 1.2 bei "keine Benutzung",
      Maximum von 1.7A beim unzippen von Arduino 1.6.9
      Kerntemperaturen im "offenen Betrieb" wie auf dem Foto zu sehen : 72°C+-2°C
      Die starken Schwankungen bei der Stromaufnahme legen nahe, das 2.0A-Spitzen durchaus möglich sind. Bei minderwertigen USB-Kabeln zur Versorgung kann es da schnell zu hohen Spannungsabfällen und Auslösen der PowerFail-ICs kommen.

      Bei Bluetooth-Kopplung ohne weitere Tasks war die Stromaufnahme bis 1.6A hoch.

      Ein Test mit Touchscreeen folgt noch.
      Ein Test mit HDMI-Kabel kommt erst in den nächsten Tagen, ebenso die Stromaufnahme bei WLAN (geht nur im Homeoffice).

      Beim Test der Grafik gingen die Kerntemperaturen schnell auf 80°C und der Takt wurde runter geregelt. Bis dahin lag die Stromaufnahme aber bei 2.4A !

      Sonstiges :
      Erste Inbetriebnahme ohne Netzwerkkabel. Nach Anschluss des LAN-Kabels (in der Firma gibt es kein WLAN) wurde ein Win10-Update gestartet. Dabei gab es einen Absturz, der aber von W10 selber behoben wurde. Das ganze hat aber mindesten 30Min. gedauert.

      Stellt man den LP senkrecht, scheint die Kühlung etwas besser zu sein. Aber in das mitgelieferte Gehäuse bau ich den NICHT ein !


      VG,
      Lodin
    • Senkrecht ist klar, da kann sich die Konvektion viel besser entwickeln. Ganz leichter Luftstrom drauf und es wird bestimmt sofort noch besser. Aber ich denke auch am besten man wird nen schönen Kühlkörper finden, das noch mit leichter Zwangsbelüftung, müßte dann die besten Temperatur Ergebnisse erzielen.

      Interessant aber schon jetzt die Strommessungen.

      Was meinst Du denn zu den Netzteilen mit 5,2V oder 5,25V wie man es Teils schon gelesen hat. Gut oder eher nicht zu empfehlen? Könnte mir vorstellen das hier Spannungsverluste der Zuleitung gleich mit Wett gemacht werden. Andererseits sind das Netzteile von Microsoft und Appl gewesen.

      Bin noch am schwanken, ob ich mir das 4A von Reichelt hole, oder ob es Sinn macht so eine leichte Überspannung zu haben. Andererseits weiß ich das die Spannungsfenster in der Microelektronik zum Teil auch recht klein sind.
    • 5.2V bei möglichen Kabelverlusten ist Kaffeesatzleserei. :???:

      Es sollten aber auf jeden Fall mehr als (geschätzte) 4.85 sein, sonst gibt es bestimmt PowerFail-Signale. Die CPU hat eh ihre eigenen Spannungsregler und der Rest verkraftet bestimmt auch 5.3V oder ist sind noch weitere Regler versteckt.

      Nimm ein 5V/3A-Netzteil (wenn der Stromverbrauch der USB-Geräte kalkulierbar ist) und ein 0.75mm²-Anschlusskabel mit nicht mehr als 0,5m Länge. Einspeisung bei dem 4pol-Verbinder mit je 2x GND und +5V... wenn man eh schon am basteln ist.
      ACHTUNG : Ausgerechnet der Steckverbinder hat keinen Verpolungsschutz.
      An den Arduino-Anschlüssen bekommt man leider schlecht ein 0.75mm² dran, die Gehäuse sind zu klein.

      Ich hab mal eins der Arduino-Sensor-Kabel als Versorgung "geopfert" um einen passenden Stecker mit Kabel zu haben. Das Kabel ist so dünn, das auf der vielleicht 15cm Länge ein Spannungsverlust von fast 100mV auftritt. <X

      Ohne "Wasserkühlung" wird der LP alleine nicht mehr als 2.5A aufnehmen denn er wird dann so heiß das er runter taktet was den Verbrauch wieder reduziert.


      Was mir noch aufgefallen ist :

      In den ersten 8-10Sek nach anschließen der Stromversorgung, also während die blaue LED blinkt, fließen bis zu 1.2 A. Keine Ahnung wer da was macht.

      Beim "Runterfahren" nachdem das LCD aus ist zieht der LP noch locker 20Sek Strom... er macht also irgendwas. Ich traue mich da nicht ihm schon den Saft ganz zu nehmen. Am Ende hat er dann eine Ruhestromaufnahme von 70mA.
      Wie stabil ist eigentlich W10 gegen einen Stromausfall im Betrieb/Runterfahren ???


      VG,
      Lodin
    • Mecki schrieb:

      Hast Du mal den aufgedruckten Anschluß CN4 zwischen / vor den USB Buchsen angeschaut? Müßte doch auch 5V und Masse sein, oder? Passenden Stecker "mit Verpolungsschutz" rein?
      Da steht aber VCC & GND dran. Bei den anderen Steckverbinder ist es +5V & GND.
      Ich messe das morgen mal nach.
      Außerdem sind bei meinen LPs dessen Lötaugen zu gelaufen. Die aufzumachen und da einen anderen Stecker einlöten riskiere ich nicht.
    • lovebunnyhunter schrieb:

      Lodin_Erikson schrieb:

      Wie stabil ist eigentlich W10 gegen einen Stromausfall im Betrieb/Runterfahren ???
      Das ist Windows 10 vollkommen egal. Hab meinen schon oft einfach so vom Strom getrennt. Vielleicht kommt mal die Recovery Konsole, aber auch da einfach neu starten und schon gehts weiter.
      Gruss
      Die Recovery Console kann ich vor den Augen meiner Kunden nicht brauchen...
    • Lodin_Erikson schrieb:

      Mecki schrieb:

      Hast Du mal den aufgedruckten Anschluß CN4 zwischen / vor den USB Buchsen angeschaut? Müßte doch auch 5V und Masse sein, oder? Passenden Stecker "mit Verpolungsschutz" rein?
      Da steht aber VCC & GND dran. Bei den anderen Steckverbinder ist es +5V & GND.Ich messe das morgen mal nach.
      Außerdem sind bei meinen LPs dessen Lötaugen zu gelaufen. Die aufzumachen und da einen anderen Stecker einlöten riskiere ich nicht.
      Bei mir ist ein Lötauge offen, das ander hat einen hochstehenden "Deckel"...

      Hast Du vielleicht mal nachgeschaut ob es abenso die 5V Verbindung ist? interessieren würds mich schonmal.

      Aber noch kurz eine andere Frage, du hast ja LCD und Bildschirm zusammen laufen gehabt, nicht?
      Mit welcher Auflösung?
      LCD Auflösung dann auf dem Monitor? Oder dort dann mehr? Oder geht das nur wenn LCD ab ist?
    • Hallo Mecki,

      ganz kurz :
      1. Das Signal "VCC" am "CN4" scheint das gleiche zu sein, das am "Batterieverbinder" auf der Lötseite anliegt, ca. 1,7V ?(
      Könnte aber für eine Huckepackplatine sinnvoll sein... wenn er denn bestückt wäre.

      2. Monitorbetrieb muss warten, ich warte auf meine Test-Platine und Bauteile. Bis jetzt nur die LCD mit Touch benutzt.


      VG,
      Lodin
    • Da bin ich jetzt etwas überrascht... dacht VCC steht für die Haupt Spannungsversorgung oder so ähnlich... so ungefähr "Master" Spannungsversorgung.... wenn man so will.

      Ok also nix mit Stecker einlöten....


      Zum Monitor, hatte Dich so verstanden, das du den LCD nur zum Testen mal dran hattest, aber richtigen Monitor benutzt, da LCD zu klein für Deine Äuglein... befürchte ich nämlich auch.... Mitterlweile sind die Arme aber sooo lang geworden, das es mit Brille wohl gehen sollte, daher LCD auch mit ausgewählt.

      Vielen Dank auch!!!!

      Mecki
    • Hallo Mecki,

      das hattest Du schon richtig verstanden, das mir das LCD zu klein ist... für Windoof.
      Aber der LP soll später als Steuerrechner mit LCD & Touch eingesetzt werden, also teste ich genau diese Konfiguration. Ein Anwendungsprogramm kann ja später eigene große Texte und Buttons benutzen...

      Für die Tests nutze ich inzwischen Teamviewer als "Vergrößerungsglas".

      "VCC" ist tatsächlich normalerweise die Versorgung. Bei Systemen mit mehreren Versorgungsspannung üblicherweise die +5V. ("VDD" ist dann meist 3.3V oder weniger). Da hattest Du also auch recht.

      Meine Testplatine ist inzwischen beim Hersteller, Bauteile sind bestellt. Vermutlich Ende nächster Woche wird gelötet.
      Hier 2 Ansichten des Entwurfs :


      Dann werden auch diverse Lüfter (40 - 60) und Kühlkörper getestet.

      Größere Lautsprecher am Kopfhörerausgang anzuschließen bringt erwartungsgemäß nichts. Also muss ich auch noch einen Audio-Verstärker auf meiner nächsten Platine unterbringen. ||


      VG,
      Lodin
    • Danke für die Rückmeldung und Bestätigungen meines Halbwissens... ;)

      Zu Deinen Bildern: Auf mich wirkt das so als wenn der Lüfter vorallem oben drauf, wenn nicht auschließlich oben drüber die Luft hinweg pustet.
      Unser Prozi sitzt aber unten drunter... ?

      Also ich wollts ja nur noch nicht so ganz sagen, weil ich da noch am suchen bin, und außerdem im Moment eh noch nicht die Zeit zum selber testen habe, aber ich spiele mit dem Gedanken eventuell einen, bzw. zwei Headpipe Kühler oder sonst wie speziellen Kühler zu nehmen. Z.B. welche die eigentlich für Chipsatzkühlung gedacht sind oder ähnliches.
      Genial wäre wenn man den eigentlichen Wärmeabgebenden Körper dann setilich neben dem LP hätte.

      Kommt sicher der Einwand wie befestigen...?
      Nun ich sehe da zwei Möglichkeiten, wobei eines dabei immer gleich bleibt: Ich würde wohl auf beiden Seiten einen Kühler verbauen und die quasi in Klappergriff nehmen, mit dem LP dazwischen.

      Ich sehe dabei zwei Möglichkeiten einen Kühlkörper festzuklemmen:
      Entweder mit einem Bügel vorne und hinten, wobei oben und unten gegeneinader gepresst werden, also zusammengeschraubt werden. Nur oben ist es auf der einen Seite etwas schwierig wo die USB Anschlüße sind, wenn man keine der Steckerverbindungen blockieren will. Grundsätzlich ließe sich das aber auch lösen...

      Die andere Möglichkeit, wie haben ja an allen vier Ecken Löcher, und so mancheiner wird hier sicher die nächste Platine mit Stangen draufschrauben. Nur wenn man da Stangen hat und zwischendrin sind Bügel zu den Kühlkörpern rüber? Sollte nicht stören.
      Die Hebelkräfte heben sich beim Klemmen gegenseitig auf.
    • Mecki schrieb:

      (...)


      Zu Deinen Bildern: Auf mich wirkt das so als wenn der Lüfter vorallem oben drauf, wenn nicht auschließlich oben drüber die Luft hinweg pustet.
      Unser Prozi sitzt aber unten drunter... ?

      (...)
      Hallo Mecki,

      auf dem Bild ist es noch ein 50x50mm²-Lüfter, aber mit dem LP auf 30mm Abstand => also nicht ganz mittig gezeichnet. Er soll aber gleichzeitig über Ober- und Unterseite pusten. Wobei die Oberseite des LP die Unterseite der Huckepackplatine ist. Auf deren Unterseite sitzt der DCDC-Wandler, also auch im Luftstrom.
      Was im Bild fehlt ist das Display, das sitzt dann in 20-30mm(?) Abstand von der Unterseite des LP. Der Luftstrom wird also quasi beidseitig über den LP geführt.
      Wobei ich immer noch hoffe, auf den Lüfter in unserer Anwendung verzichten zu können. Aber im inneren das Gerätes in das er soll ist es schon ziemlich warm... :/

      Heatpipes gehen bei uns schon konstruktiv nicht und die Befestigungsprobleme des ganzen Sandwiches mit Lüfter soll unser Mechaniker lösen... ich mach das mit einer ordentliche Portion Silikon... :twisted: :twisted:


      VG,
      Lodin
    • Mecki schrieb:

      Naja, je nachdem wie das ganze am Ende ausschaut, könnte man auch eine Seite (Rückwand?) aus Allukörper mit dezenten Rippen bauen. Mit der könnte man dann zugleich nebenbei die Wärme abführen... auf ner großen Fläche verteilt, dürfte das auch niemals all zu warm werden, denke ich mal.
      Bei dem von Varona
      Verkaufe Lattepanda 2/32GB 85€ inc. Versand.

      (sieht man aber nicht viel von auf dem Video)
      ist ein Kühlkörper ca. 1,5 mal so groß wie die Fläche über der CPU drauf. Damit bleibt der LP bei 1,6Ghz Vollast bei etwa 70 Grad (OHNE Lüfter), je nachdem wo ich ihn hinstelle und welcher Kern etwas drüber oder drunter.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von LennStar ()

    • 70°C, noch ganz schön viel finde ich... oder?
      Eigentlich hört sich das für mich so an, als wenn die Wärmeabgabe noch nicht optimal ist.

      Wenn ich mir das anschaue, denke ich könnte man da auch gleich nen größeren Kühler drauf setzen wenn der Lüfter schon so groß ist, oder?
      Problem finde ich auch, das die Lüfter Mitte, aus der ja keine Luft kommt gerade genau über der Mitte des Kühlkörpers steht... und genau unter dem Punkt entsteht auch die Wärme, außerdem drücken die Lüfter ringsrum neue Luft runter, wenn man sich das mal überlegt, könnte man sich auch vorstellen das sich die Luft in der Mitte quasi staut, nicht weg kommt...
      Naja, wird sich schon irgendwie verwirbeln, aber im Grunde wäre ein richtiger durchfluß schon noch besser...